Announcement Customer Support: Holiday Support Availability 2025

Incident Report for AddSecure Services

Update

We are continuing to investigate this issue.
Posted Dec 23, 2025 - 09:03 CET

Investigating

Dear Customer,

Between Christmas and New Year (23rd of December 2025 - 2nd of January 2026), our team will be operating with a skeleton crew to assist you with any requests or issues.
We remain committed to supporting you during this period, but please note that response times may be longer than usual.
We appreciate you're understanding and patience, and we wish you a wonderful holiday season!

Best regards,

Your AddSecure Customer Support Team
Posted Dec 15, 2025 - 13:39 CET
This incident affects: Announcement.