Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 22, 2025 - 10:00 CEST
Scheduled
Dear customer, On Monday, 22nd of September at 10.00 CET our engineering team will be verifying the plugin in DASH. We do not expect any downtime during that timeslot.
Please, be informed that if we notice any possible DASH disturbance, we will update you.
Thank you for your understanding.
Posted Sep 16, 2025 - 10:25 CEST
This scheduled maintenance affected: FleetVisor (DASH).