Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2025 - 18:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted May 28, 2025 - 16:26 CEST
Scheduled
Please be advised that starting tonight at 18:00, we will be conducting an investigation on FleetVisor. During this time, you may experience minor delays in MT Messages and position updates. We appreciate your understanding and patience.
Posted May 28, 2025 - 16:03 CEST
This scheduled maintenance affected: Announcement.