SIM provider is currently experiencing a service outage

Incident Report for AddSecure Services

Resolved

The outage has been resolved, and the service has been restored
Posted Sep 30, 2025 - 15:47 CEST

Identified

We would like to inform you that one of our SIM providers is currently experiencing a service outage on their network. The issue has already been identified, and their technical teams are actively working on a fix.
This outage may cause temporary disturbances in DriverLinc connectivity at your location.
We appreciate your understanding.
Posted Sep 30, 2025 - 13:23 CEST
This incident affected: Announcement.