Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 23, 2025 - 20:00 CEST
Scheduled
We are ready for first step of improving the Single-Sign-On experience.
In this first step following changes will be introduced:
• Unified login pop-up: Users will be able to enter their SSO username and password in the same pop-up window. • ‘Keep me signed in for 14 days’ option: A checkbox will be added to allow users to stay signed in for 14 days without having to re-enter their credentials.
If you have any further questions, please be so kind to reach out to us.
Posted Jul 22, 2025 - 14:28 CEST
This scheduled maintenance affected: FleetVisor (FleetVisor Next User Interface, Third Party Integration).