Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 27, 2025 - 20:00 CEST
Scheduled
Planned Maintenance: Upgrade FleetVisor Now, FleetVisor next version 2025.5
On the 27th of May 2025 from 08:00PM CEST to 11:00PM CEST we will perform an upgrade to our FleetVisor Now, FleetVisor next Data center.
During the release window of 180min the FleetVisor Next, FleetVisor Now, TripMonitor User Interface and TPI service will be inaccessible for all users.
All data-traffic will be queued and processed once all services are back online.
Posted May 22, 2025 - 17:57 CEST
This scheduled maintenance affected: Service Partners (Mapping Services, Telecommunication Services, TrailerLincv3 data, 3rd party hardware devices, AGS), TripMonitor (TripMonitor User Interface, TripMonitor Data Processing, Third party Integration), FleetVisor (FleetVisor Now User Interface, FleetVisor Next User Interface, FleetVisor Data Processing, Remote Tacho Download Service, Third Party Integration, DASH), and Mobile Application Services (Mission Planner, AppLinc).