Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2025 - 21:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 23, 2025 - 14:56 CEST
Scheduled
Today, the 23 of June 2025, from 21.00 CEST to 21.30 CEST we need to perform a small maintenance of the DASH. During this period DASH will be not available. No data will be lost. Thank you for your understanding.
Posted Jun 23, 2025 - 14:52 CEST
This scheduled maintenance affected: FleetVisor (DASH).